태터데스크 관리자

도움말
닫기
적용하기   첫페이지 만들기

태터데스크 메시지

저장하였습니다.

React-Native로 프로젝트 생성 시 아래와 유사한 오류가 발생하는 경우가 있다.

이 경우 React-Native의 버전에 따라 발생한다.

React-Native는 아직 정식 버전이 배포되지 않아 해당 오류가 빈번히 발생 할 것으로 생각됩니다.



import type {CommandT} from './commands';

       ^^^^


SyntaxError: Unexpected identifier

    at new Script (vm.js:74:7)

    at createScript (vm.js:246:10)

    at Object.runInThisContext (vm.js:298:10)

    at Module._compile (internal/modules/cjs/loader.js:657:28)

    at Module._compile (D:\Project\01.Private\02.React-Native\EnglishPhrase\node_modules\pirates\lib\index.js:91:24)

    at Module._extensions..js (internal/modules/cjs/loader.js:700:10)

    at Object.newLoader [as .js] (D:\Project\01.Private\02.React-Native\EnglishPhrase\node_modules\pirates\lib\index.js:96:7)

    at Module.load (internal/modules/cjs/loader.js:599:32)

    at tryModuleLoad (internal/modules/cjs/loader.js:538:12)

    at Function.Module._load (internal/modules/cjs/loader.js:530:3)

 



해결 방법은 컴파일 이 잘되는 버전으로 프로젝트를 만드는 것이다.

구글링을 통해 "0.55.4" 버전이 안정적인 것을 알게되었다.

React-Native 프로젝트를 생성 때 버전정보를 넣고 생성하면 오류가 해결된다.


 react-native init --version="0.55.4" ProjectName




블로그 이미지

Dokon Jang

댓글을 달아 주세요